(generation required)

I've upgraded to:

MPS 234

IDEA 4081

Now in MPS the Langauge node always has "(generation required)" beside it. The generated code looks fine and update2date, no errors etc..

Should I be concerned about this, or just continue to ignore it?

2 comments
Comment actions Permalink

RefuX Zanzeebarr wrote:

I've upgraded to:

MPS 234

IDEA 4081

Now in MPS the Langauge node always has "(generation required)" beside it. The generated code looks fine and update2date, no errors etc..

Should I be concerned about this, or just continue to ignore it?

Generation Required is shown if timestamp of model is older than

timestamp of files in directory to which files generated. Could you

provide more information about thing that are you doing. What OS do you

use? Did you change output directory in language properties. This looks

like a bug.

0
Comment actions Permalink

I can recreate the bug by going through 'TheSimplestLangauge' tutorial.

System info:

OS: Windows XP SP2

JAVA: Java 5 Update 6

If I close MPS and then reopen it, it says 'up-to-date' but once I change the model and regenerate it just stays on 'generation required'

In my current project (not TheSimplestLangauge):

My 'source_gen' dir is quite old, all the files and dir's in it have a timestamp between 10:54am and 10:55am.

My structure.mps has a timestamp of 10:52am.

Need any more info give me a yell.

0

Please sign in to leave a comment.