Cannot connect to Idea

Hello people.

I got very interested in MPS in its early days, I think first build I tried out was 160 or something :-) I haven't checked it out since then, and today I decided to see how much has it improved. I must say, you Jetbrains guys keep to amaze me every day more and more. This piece of software is amazing and the potential in idea of LOP is even more awesome.

I do post because I have a problem thought. When I run MPS, it messages that it cannot connect to Idea. I've found menu command that installs plugint to Idea, and I've restarted it but I haven't found any new plugins in the list. Also, after restarting MPS, it stills claims it cannot connect.

I usually run EAP versions of Idea, and I run in linux environment.

I'll gladly post more informations to get this thing running, I am very interested in giving it a try in one prototype framework I want to build.

Thanks in advance, and please keep this project alive. It is an amazing achievement, both creatively and functionally.

1 comment
Comment actions Permalink

Hello, Deus.

You don't need IDEA plugin in order to develop languages in MPS anymore. By default all stuff that generated from your code is compiled internally by MPS (we use ECJ compiler). So you can safely ignore these error messages.

Regards,

Konstantin Solomatov

0

Please sign in to leave a comment.