Claculator tutorial problem about reference macro

I'm stuck at the point where the mapping labels and reference macro.

1.  I set "InputFieldDeclaration","InputField","FieldDeclaration" to the main window. It's OK.

2.  I set "InputFieldDeclaration" to the $LOOP$'s Inspecter window. It's also OK.

3.  I put  cusor on "inputFiled" in "this.inputField.getDocument()..." and  pushed ALT ENTER, but nothing happened.

    In tutorial  intentions popup window was displayed and you could select "Add Reference Macro",  but I could'nt.

4.  I tried  many times ,but result are always same.

5.  I also woderd about next problem. I generated text without reference macro, and found the result program text was same as toutorial's sample program text in few pages later.

What's this problem?

5 comments
Comment actions Permalink

What version of MPS are you using? Could you attach directory with your tutorial project?

0
Comment actions Permalink

Evgeny

Hi, Evgey

This problem occurred in MPS1.0.

Recently I version upped from MPS1.0 to MPS1.1, but this problem  continuously occrred.

I put my MPSProjects FIle in ZIP form.

Please check it, and give me some advices.
 



Attachment(s):
MPSProjects.zip
0
Comment actions Permalink

Hi,

I tried to use CTL Shift M to this problem.

And this time another popup window was displyed.

In this window I can select "Add reference macro" and I can put

reference macro to inputField same as toutorial.

Is this operation correct action?

I'm going through toutorial's next steps.

If this operation is not proper one,

please recommend proper one.

Thanks

0
Comment actions Permalink

Hi Saburo,

I investigated your problem. Alt+Enter intention really does not work for “inputField” node. I have submitted this problem to issue tracker: http://youtrack.jetbrains.net/issue/MPS-7128. It will be fixed for the next major version. By the way, you can subscribe to history of issue in tracker and report bugs directly there.

Using Ctrl+Shift+M instead of Alt+Enter for adding macros in templates is correct, these actions do exactly the same.

You said that you generated your program without reference macro and result was the same as in the tutorial. That is really so, but it is not recommended to skip using reference macros, because in this way, correct generation is not guaranteed

Thank you for you feedback.

0
Comment actions Permalink

Hi Evgeny,

as the problem is still appearing it would be very nice if you could mention in the tutorial that the other shortcut (ctrl+m) is needed at that point.

By the way: MPS is great!

Cheers

Yann

0

Please sign in to leave a comment.