InferenceMethod annotation red in 2.0

In my MPS project I use the InferenceMethod annotation on several static methods on a class so I can call the methods from Typesystem code. In 2.0 the annotation is showing red, and if I delete it I'm unable to select it again from the attribute list. If I go to reference on an existing one I can get the definition fine, but it seems to be out of scope.

Is there a new way of doing this, or is something wrong w/ the scoping, or ?
2 comments
I tried it on new project and I can:
  • import jetbrains.mps.lang.typesystem.dependencies model into typesystem aspect of new language
  • create new class with static method
  • add InferenceMethod annotation this static method

in case you are still experiencing this problem with MPS 2.0 please file a request for it.
0
I had to do the first step. It's odd things were working fine in 1.5, but in the 2.0 update this now became necessary. I don't recall manually adding that import in the past.

Also before manually adding the import I tried the "Fix Missing Imports" command in the submenu of the typesystem aspect and this didn't seem to fix the problem.

Thanks
0

Please sign in to leave a comment.