2.5.1 - can't get Calculator tutorial work

Sorry for possibly stupid question, but I'm new in MPS, I'd like to use it in my future projects, and it seems that I just can't get started with it because one of the steps in the tutorial doesn't work - the part when I create InputFieldReference concept, define an editor for it, compile the language and try it in sandbox model. According to the tutorial, now I can see named references to the input fields of a calculator - but I don't! I tried Ctrl+Space or just write in the name, but none of two worked. All I can choose is just basic Expressions.
Is there any known issue about this?

---
MPS Version: 2.5.1 (117.9271)
4 comments
I'm surprised that the reference doesn't work for you. I suspect something might be wrong in the InputFieldReference definition.
Can you share the project so I could have a look at it, please?
0
Checked once again, everything seems to be properly written, and still references are not shown in auto-complete box.
tutorial.zip (331KB)
0
OK, two things:
1. InputFieldReference has to extend Expression, not BaseConcept, in order to participare in expressions
2. The sandbox module should mention j.m.baseLanguage among the "Use Languages"
0

Please sign in to leave a comment.