Error: dependencies should be extracted into build script....


so today I updated MPS and as expected, a few things do not work anymore, especially, building a plugin! So since today MPS is crying for some build script for my dependencies, yet, I do not know where they should come from, what they should contain and, well yeah, their overall purpose. Hence, I tried to use the BuildSolutionWizard, but, unfortunately, it produces build models with errors, in fact, again, the missing build scripts. Unfortunately, MPS homepage and documentation still suffer from being up-to-date (in fact, the documentation shows the erroneous build model), hence my question to the forum, anyone got any ideas what this error (see heading of thread) means and how to fix it?

Solved...somehow MPS produced errors and entries need to be done manually...


Also, Inspector by Alt+2 on Windows7 64bit doesn't work anymore, instead, it shows Recent opened project (or something alike)
Hi Phil,
What do you mean by : entries need to be done manually.
I have the same problem, it is complaining about missing dependencies:

extends language dependency should be extracted into build script: f3061a53-9226-4cc5-a443-f952ceaf5816(jetbrains.mps.baseLanguage)

I can not find the way to add those depencied into the script language.


Hi, Hykiukira,

You can do it this way: use "Check Model" action on the model with build scripts (available from the project pane model context menu) which will show all the problems in the scripts. Most of them could be fixed automatically, so you can select "Perform Quick Fixes" button in the Model Checker window. If there are some problems that can not be fixed automatically, there could be several reasons to this:
  1. Module A from script "buildA" depends on module B from script buildB, but buildA does not depend on buildB. This can be fixed by adding the dependency from buildA on buildB.
  2. There are some circular dependencies between build scripts. That should be addressed by manually removing circular dependencies.

After all dependencies are added and scripts are generated they will have two new targets: cleanSources and generate, which can clean generated files and generate. But in order to be able completely generate all modules from scratch one have to ensure that there are no bootstrapping dependencies between modules. There is an article "Removing bootstrapping dependency problems" about that which explains this stuff in detail.


I had today the same issue. To fix it click on the red light bulp and choose load module from disk. 


Please sign in to leave a comment.