EAP questions

I've been working with the latest EAP and have a couple of questions/issues:

1) on osx, I can't get java runtime configurations to work at all.  If I try to create a new configuration, or even set the defaults, I get a stack dump.  Is this a known issue?  I'm using the latest Apple version of the 1.6 jdk.  Is there possibly a new requirement for 1.7 that I missed?

2) Is it possible to use the mps plugins with Intellij for a non-Java project?  For example, I've been using it for a lot of web/node.js development, and I'm creating some mps languages for json, javascript, etc.  I would like to use those languages in a plain web project in idea, but I can't seem to get it to work.  I could never get this working with 2.5 either, but I'm hoping the situation has improved (with full ide integration being one of the main features in 3.0).

3) I can't find the gtext language anywhere in 3.0.  What happened (and please don't say you dropped it)?
3 comments
3) I can't find the gtext language anywhere in 3.0. What happened (and please don't say you dropped it)?

gtext is obsolete and has been removed from the main MPS distribution. You can download it separately (see MPS-3.0-EAP-129.120-contrib.zip on the EAP download page) if you need it.
0
Ok, I found it.  I looked there before, but for some reasons it's under the mps-xml-obsolete folder (seems out of place).

I'm wondering why gtext is considered obsolete?  Have there been improvements to textgen or some other alternate generation language introduced that I'm not aware of?
0
How do I import gtext in mps 3.0? I have downloaded MPS-3.0-EAP-129.120-contrib.zip
0

Please sign in to leave a comment.