Hot key to create a new concept?

There is a shortcut to create a new concept (or other root nodes), as i could see from (i think) Constants language tutorial, part 1. What is it?
9 comments
Insert / Control + N
However, seems to be somewhat broken in recent 3.0
0
Maybe it is just not assigned in keymap? How should it be called?


On Tue, Jul 2, 2013 at 5:19 PM, Vaclav Pech - Meta Programming System <
jetforum@jetbrains.com> wrote:

* Meta Programming System<http://forum.jetbrains.com/forum/Meta-Programming-System>
* > * Hot key to create a new concept?<http://forum.jetbrains.com/thread/Meta-Programming-System-854>
* 9:19 am<http://forum.jetbrains.com/thread/Meta-Programming-System-854?message=Meta-Programming-System-854-1>  Vaclav
Pech <http://forum.jetbrains.com/user/venca>

Insert / Control + N
However, seems to be somewhat broken in recent 3.0

   VABAV <http://forum.jetbrains.com/user/VABAV> @ 8:26 am<http://forum.jetbrains.com/thread/Meta-Programming-System-854>

There is a shortcut to create a new concept (or other root nodes), as i
could see from (i think) Constants language tutorial, part 1. What is it?

  JetBrains Forum | Build #171 (Jun/07/2013 10:26AM) | Feedback<http://confluence.jetbrains.net/display/JETF/Feedback>
0
Yeah, it is not assigned. It seems it should be in section Plugins/jetbrains.mps.ide, action "Create". But also it should be noted that this shortcut is not reflected here
0
<table width="100%" cellspacing="0" border="0"><tbody><tr><td align="left"><table width="80%" cellspacing="5" cellpadding="0" border="0"><tbody><tr><td><table width="100%" cellspacing="0" cellpadding="0" border="0"><tbody> <tr><td> <a href="http://youtrack.jetbrains.net/issue/MPS-18108">MPS-18108</a> Unassigned "Create" (root node) shortcut (MPS 3.0)</td></tr> <tr><td>Shortcut to create a new root node is not assigned in MPS 3.0 (recent).<br>It is located in Plugins/jetbrains.mps.ide/Create in keymap. </td></tr> <tr><td>Normal | Bug | Duplicate | Not assigned</td></tr> </tbody></table></td></tr></tbody></table></td></tr></tbody></table>
0
Thanks for investigation. I added the shortcut to the page and reported the issue - http://youtrack.jetbrains.com/issue/MPS-18108
0
BTW, why is link to the forum comment in the issue is not working in Chrome? Or is it only in my browser?
0
Neither for me. I have no idea why yours doesn't work, but I pasted the link again just below.
0
Maybe it's a bug in JetBrains Forum/YouTrack?
0
If you manage to reproduce the problem, then it may be worth reporting.
0

Please sign in to leave a comment.