Unable to make use of the CellModel_Table


currently I simply want to try out the Decision Table example from the screencast (jetbrains tv).
The problem is: Building the concept works fine but when I move over to designing the editor I'm not able to reference the table cell model from jetbrains.mps.lang.editor.table.structure as shown in the screencast. It is simply not available when I search the code completion menu.

This is what I've done so far:
1. I created my new language inside a new project
2. I added jetbrains.mps.lang.editor.table to the "Used Languages" section of the language properties
3. I also added the jetbrains.mps.lang.editor.table.runtime solution to the dependencies.
4. I built the new concept completely identical to the DecisionTable concept in the screencast.
5. I moved over to the editor definition and there I'm stuck.

It would be great if anybody could help me since I have no idea what the reason for this issue could be.

Thank you in advance and have a nice weekend,
Comment actions Permalink
one minute after I started this thread I had an idea - and now it works.
The solution was: Add jetbrains.mps.lang.editor.table also to the "Used Languages" of the MODEL properties. Adding it to the language properties is insufficient. It currently must be added to BOTH.

Nevertheless I think that this behavior is odd since I would expect that the language properties are inherited by all parts of this particular language. Maybe they can be overrided.
Maybe this is an issue you (@developers) should consider for the next release.

Thank you in advance,
Comment actions Permalink

Thank you Lars, that works!

Comment actions Permalink

Thank you! Worked also for me - a newbie in the Jetbrains MPS world :D


Please sign in to leave a comment.