Unable to convert .mps to .mpb in MPS-RC1-3.2 BUILD-139.1759

Hi ,

When I tried building the language using ant, ant throws me the following error

Cannot convert .mps into .mpb: Argument for @NotNull parameter 'concept' of jetbrains/mps/persistence/registry/IdInfoRegistry.knows must not be null

I tried to convert individual model to binary format and build the language, But still the problem is not resolved.

Please help me regarding this.

Thanks in advance.

Regards,

Dinesh
2 comments
Has your language been created in 3.2 rc1? If it was created in an older version, did you run all the MPS migrations - Tools -> Start Migration Assistant?
0
Hi Vaclav,

Thank you very much for the assistance. :)

My language was created in 3.1 and so I did all migrations as you said.

When I did Migration, I was not sure whether the migration really happened or not.

So I created a new project and added my language in the project path and then migrated that project. Now I have no problems :)

Regards,

Dinesh
0

Please sign in to leave a comment.