Migration lead to empty project

Hi,

I recently tried to migrate my languages to MPS 3.2 (3.2.2 is not possible, yet). The migration assistant seemed to complete the migration successfully. Now when I open my project, it is empty, i.e. now languages, solutions, etc. are shown. When I try to edit the Project Paths, the respective dialogue does not show up.

Did anybody encounter the same issue? If yes, how did you solve it?

Thank you very much in advance,
LaAck
4 comments
This is definitely not what should be happening.
Was your project in the 3.1 format before? You could try manually deleting the generated sources before opening the project and migrating, although the migration wizard is supposed to delete them automatically.
0
Hi Vaclav,

thank you very much for your fast reply. Yes, the project was in the 3.1 format before. I'll try your suggestion before opening the project and migrating. I will write a comment if it was successful.

LaAck
0
Hi again,

I'm afraid your suggestion does not work. I deleted the generated sources. But my generator depends on a language module within the project. If I delete the sources, the Model Checker shows errors and therefore the Migration Assistant refuses migrating the languages.

I don't know how to fix this issue.
0
Ok, now I solved the problem. The migration failed because of an imported MPS language (math language from sample projects). While I never had to build the language in order to combine it with my own language, the Migration Assistant was impeded. So I removed it from my project and added the new version after migration.
0

Please sign in to leave a comment.