Cannot load project: Fatal error initializing 'jetbrains.mps.project.MPSProject'

Hi,

I migrated my projects to MPS 3.4.2, everything worked automatically. After I restarted MPS, I cannot open any project anymore: 

I re-installed MPS, with the same result, any ideas?

 

2 comments
Comment actions Permalink

This seems to be related with having a build solution in place. When I go into the "\.mps\modules.xml" file and comment out the two lines with the APPLICATIOn_PLUGINS_DIR property, MPS is able to load my project again.



I do not know where the property $APPLICATION_PLUGINS_DIR$ points to, but the path behind it seems fishy, since I don't seem to have this sub-path anywhere.

0
Comment actions Permalink

Hi Robert!

It looks like 2 bugs to me. One is that MPS won't start when there are wrong paths in modules.xml. And second, that those paths appeared in modules.xml in the first place. Would you please file those to our youtrack?

As for the second one, do you have an idea when those paths sneaked into the file? Is it definitely during migration? Maybe, vcs can be of help to determine. If you could reproduce, that would be very helpful.

I didn't understand what it has to do with a build solution that you mention. Could you elaborate?

Fwiw, that path variable (APPLICATION_PLUGINS_DIR) is a special variable that intellij platform provides and it points to plugins dir of the currently running intellij based application, say MPS.

0

Please sign in to leave a comment.