MPS plugin fails to load (Unsupported version)

I'm on OS X (10.4.2) with Java 1.5.  I've tried using MPS with 3 versions of IDEA (3415, 3429, 3431).  All of them give me this exception on startup, I assume when trying to load the MPS plugin.  What's up?

Original exception: jetbrains/mps/plugin/XMLRPCServer (Unsupported major.minor version 49.0)

java.lang.UnsupportedClassVersionError: jetbrains/mps/plugin/XMLRPCServer (Unsupported major.minor version 49.0)

    at java.lang.ClassLoader.defineClass0(Native Method)

    at java.lang.ClassLoader.defineClass(ClassLoader.java:539)

    at java.lang.ClassLoader.defineClass(ClassLoader.java:448)

    at com.intellij.ide.plugins.cl.IdeaClassLoader.a(IdeaClassLoader.java:13)

    at com.intellij.ide.plugins.cl.IdeaClassLoader.findClass(IdeaClassLoader.java:10)

    at com.intellij.ide.plugins.cl.PluginClassLoader.loadClass(PluginClassLoader.java:46)

    at java.lang.ClassLoader.loadClass(ClassLoader.java:235)

    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)

    at java.lang.Class.forName0(Native Method)

    at java.lang.Class.forName(Class.java:219)

    at com.intellij.openapi.components.impl.ComponentManagerImpl.loadComponentsConfiguration(ComponentManagerImpl.java:134)

    at com.intellij.openapi.application.impl.ApplicationImpl.c(ApplicationImpl.java:15)

    at com.intellij.openapi.application.impl.ApplicationImpl.(ApplicationImpl.java:111)     at com.intellij.openapi.application.ex.ApplicationManagerEx.createApplication(ApplicationManagerEx.java)     at com.intellij.idea.IdeaApplication.(IdeaApplication.java:45)

    at com.intellij.idea.Main.a(Main.java:14)

    at com.intellij.idea.Main.access$000(Main.java:9)

    at com.intellij.idea.Main$2.proceed(Main.java:1)

    at com.intellij.ide.license.impl.IdeaLicense$1.proceed(IdeaLicense.java:5)

    at com.intellij.ide.license.policy.Proceed.check(Proceed.java)

    at com.intellij.ide.license.impl.LicenseAuthorizorImpl.checkPolicy(LicenseAuthorizorImpl.java:5)

    at com.intellij.ide.license.impl.LicenseAuthorizorImpl.checkPolicy(LicenseAuthorizorImpl.java:8)

    at com.intellij.ide.license.impl.IdeaLicense.startUp(IdeaLicense.java:63)

    at com.intellij.idea.Main.mainImpl(Main.java:46)

    at com.intellij.idea.Main.start(Main.java:27)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

    at java.lang.reflect.Method.invoke(Method.java:324)

    at com.intellij.ide.plugins.PluginManager$5.run(PluginManager.java:6)

    at java.lang.Thread.run(Thread.java:552)

com.intellij.diagnostic.PluginException: jetbrains/mps/plugin/XMLRPCServer (Unsupported major.minor version 49.0)

    at com.intellij.openapi.components.impl.ComponentManagerImpl.loadComponentsConfiguration(ComponentManagerImpl.java:31)

    at com.intellij.openapi.application.impl.ApplicationImpl.c(ApplicationImpl.java:15)

    at com.intellij.openapi.application.impl.ApplicationImpl.(ApplicationImpl.java:111)     at com.intellij.openapi.application.ex.ApplicationManagerEx.createApplication(ApplicationManagerEx.java)     at com.intellij.idea.IdeaApplication.(IdeaApplication.java:45)     at com.intellij.idea.Main.a(Main.java:14)     at com.intellij.idea.Main.access$000(Main.java:9)     at com.intellij.idea.Main$2.proceed(Main.java:1)     at com.intellij.ide.license.impl.IdeaLicense$1.proceed(IdeaLicense.java:5)     at com.intellij.ide.license.policy.Proceed.check(Proceed.java)     at com.intellij.ide.license.impl.LicenseAuthorizorImpl.checkPolicy(LicenseAuthorizorImpl.java:5)     at com.intellij.ide.license.impl.LicenseAuthorizorImpl.checkPolicy(LicenseAuthorizorImpl.java:8)     at com.intellij.ide.license.impl.IdeaLicense.startUp(IdeaLicense.java:63)     at com.intellij.idea.Main.mainImpl(Main.java:46)     at com.intellij.idea.Main.start(Main.java:27)     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)     at java.lang.reflect.Method.invoke(Method.java:324)     at com.intellij.ide.plugins.PluginManager$5.run(PluginManager.java:6)     at java.lang.Thread.run(Thread.java:552) Caused by: java.lang.UnsupportedClassVersionError: jetbrains/mps/plugin/XMLRPCServer (Unsupported major.minor version 49.0)     at java.lang.ClassLoader.defineClass0(Native Method)     at java.lang.ClassLoader.defineClass(ClassLoader.java:539)     at java.lang.ClassLoader.defineClass(ClassLoader.java:448)     at com.intellij.ide.plugins.cl.IdeaClassLoader.a(IdeaClassLoader.java:13)     at com.intellij.ide.plugins.cl.IdeaClassLoader.findClass(IdeaClassLoader.java:10)     at com.intellij.ide.plugins.cl.PluginClassLoader.loadClass(PluginClassLoader.java:46)     at java.lang.ClassLoader.loadClass(ClassLoader.java:235)     at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)     at java.lang.Class.forName0(Native Method)     at java.lang.Class.forName(Class.java:219)     at com.intellij.openapi.components.impl.ComponentManagerImpl.loadComponentsConfiguration(ComponentManagerImpl.java:134)     ... 20 more java.lang.UnsupportedClassVersionError: jetbrains/mps/plugin/ProjectCreator (Unsupported major.minor version 49.0)     at java.lang.ClassLoader.defineClass0(Native Method)     at java.lang.ClassLoader.defineClass(ClassLoader.java:539)     at java.lang.ClassLoader.defineClass(ClassLoader.java:448)     at com.intellij.ide.plugins.cl.IdeaClassLoader.a(IdeaClassLoader.java:13)     at com.intellij.ide.plugins.cl.IdeaClassLoader.findClass(IdeaClassLoader.java:10)     at com.intellij.ide.plugins.cl.PluginClassLoader.loadClass(PluginClassLoader.java:46)     at java.lang.ClassLoader.loadClass(ClassLoader.java:235)     at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)     at java.lang.Class.forName0(Native Method)     at java.lang.Class.forName(Class.java:219)     at com.intellij.openapi.components.impl.ComponentManagerImpl.loadComponentsConfiguration(ComponentManagerImpl.java:134)     at com.intellij.openapi.application.impl.ApplicationImpl.c(ApplicationImpl.java:15)     at com.intellij.openapi.application.impl.ApplicationImpl.(ApplicationImpl.java:111)     at com.intellij.openapi.application.ex.ApplicationManagerEx.createApplication(ApplicationManagerEx.java)     at com.intellij.idea.IdeaApplication.(IdeaApplication.java:45)

    at com.intellij.idea.Main.a(Main.java:14)

    at com.intellij.idea.Main.access$000(Main.java:9)

    at com.intellij.idea.Main$2.proceed(Main.java:1)

    at com.intellij.ide.license.impl.IdeaLicense$1.proceed(IdeaLicense.java:5)

    at com.intellij.ide.license.policy.Proceed.check(Proceed.java)

    at com.intellij.ide.license.impl.LicenseAuthorizorImpl.checkPolicy(LicenseAuthorizorImpl.java:5)

    at com.intellij.ide.license.impl.LicenseAuthorizorImpl.checkPolicy(LicenseAuthorizorImpl.java:8)

    at com.intellij.ide.license.impl.IdeaLicense.startUp(IdeaLicense.java:63)

    at com.intellij.idea.Main.mainImpl(Main.java:46)

    at com.intellij.idea.Main.start(Main.java:27)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

    at java.lang.reflect.Method.invoke(Method.java:324)

    at com.intellij.ide.plugins.PluginManager$5.run(PluginManager.java:6)

    at java.lang.Thread.run(Thread.java:552)

com.intellij.diagnostic.PluginException: jetbrains/mps/plugin/ProjectCreator (Unsupported major.minor version 49.0)

    at com.intellij.openapi.components.impl.ComponentManagerImpl.loadComponentsConfiguration(ComponentManagerImpl.java:31)

    at com.intellij.openapi.application.impl.ApplicationImpl.c(ApplicationImpl.java:15)

    at com.intellij.openapi.application.impl.ApplicationImpl.(ApplicationImpl.java:111)     at com.intellij.openapi.application.ex.ApplicationManagerEx.createApplication(ApplicationManagerEx.java)     at com.intellij.idea.IdeaApplication.(IdeaApplication.java:45)

    at com.intellij.idea.Main.a(Main.java:14)

    at com.intellij.idea.Main.access$000(Main.java:9)

    at com.intellij.idea.Main$2.proceed(Main.java:1)

    at com.intellij.ide.license.impl.IdeaLicense$1.proceed(IdeaLicense.java:5)

    at com.intellij.ide.license.policy.Proceed.check(Proceed.java)

    at com.intellij.ide.license.impl.LicenseAuthorizorImpl.checkPolicy(LicenseAuthorizorImpl.java:5)

    at com.intellij.ide.license.impl.LicenseAuthorizorImpl.checkPolicy(LicenseAuthorizorImpl.java:8)

    at com.intellij.ide.license.impl.IdeaLicense.startUp(IdeaLicense.java:63)

    at com.intellij.idea.Main.mainImpl(Main.java:46)

    at com.intellij.idea.Main.start(Main.java:27)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

    at java.lang.reflect.Method.invoke(Method.java:324)

    at com.intellij.ide.plugins.PluginManager$5.run(PluginManager.java:6)

    at java.lang.Thread.run(Thread.java:552)

Caused by: java.lang.UnsupportedClassVersionError: jetbrains/mps/plugin/ProjectCreator (Unsupported major.minor version 49.0)

    at java.lang.ClassLoader.defineClass0(Native Method)

    at java.lang.ClassLoader.defineClass(ClassLoader.java:539)

    at java.lang.ClassLoader.defineClass(ClassLoader.java:448)

    at com.intellij.ide.plugins.cl.IdeaClassLoader.a(IdeaClassLoader.java:13)

    at com.intellij.ide.plugins.cl.IdeaClassLoader.findClass(IdeaClassLoader.java:10)

    at com.intellij.ide.plugins.cl.PluginClassLoader.loadClass(PluginClassLoader.java:46)

    at java.lang.ClassLoader.loadClass(ClassLoader.java:235)

    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)

    at java.lang.Class.forName0(Native Method)

    at java.lang.Class.forName(Class.java:219)

    at com.intellij.openapi.components.impl.ComponentManagerImpl.loadComponentsConfiguration(ComponentManagerImpl.java:134)

    ... 20 more

2 comments
Comment actions Permalink

Doug McBride wrote:    

I'm on OS X (10.4.2) with Java 1.5.  I've tried using MPS with 3 versions of IDEA (3415, 3429, 3431).  All of them give me this exception on startup, I assume when trying to load the MPS plugin.  What's up?

It looks like you are using JDK1.4 somewhere.

0
Comment actions Permalink

Thank you!  I didn't know IDEA was conifgured to use 1.4 by default on my machine.  That did the trick.

0

Please sign in to leave a comment.