IntelliJ IDEA 12 / MPS 2.5.3 Plugins / OpenJDK 1.7.0.1 / Fedora16

I did step by step from JetBrains TV session: "How to enable MPS in IntelliJ IDEA" - http://tv.jetbrains.net/videocontent/how-to-enable-mps-in-intellij-idea

IntelliJ IDEA dialog "Choose Main Class" isn't working. It's impossible to select the Demo class from the MPS Project Demo.

When starting IntelliJ IDEA 12, first message is:
  
[Techniker@L3F591407 Downloads]$ idea-IC-123.169/bin/idea.sh
OpenJDK Runtime Environment (fedora-2.3.5.fc16-i386)
OpenJDK Server VM (build 23.2-b09, mixed mode)
WARNING: You are launching the IDE using OpenJDK Java runtime.

         ITS KNOWN TO HAVE PERFORMANCE AND GRAPHICS ISSUES!
         SWITCH TO THE ORACLE(SUN) JDK BEFORE REPORTING PROBLEMS!

NOTE:    If you have both Oracle (Sun) JDK and OpenJDK installed
         please validate either IDEA_JDK, JDK_HOME, or JAVA_HOME environment variable points to valid Oracle (Sun) JDK installation.
         See http://ow.ly/6TuKQ for more info on switching default JDK.

Press Enter to continue.

Bildschirmfoto am 2013-02-15 00:35:57.png
2 comments
..seems that my eyes are going blind late in the night,'cause didn't read the info/warning from make "Compilation completed successfully with 1 warning in 3 sec" / "Compiler setting "Use external build" should be switched off to generate MPS code". What means not nothing more, than open the IntelliJ IDEA "Settings" under "File" and deactivate the "Compiler" Option "Use external build".
  
Bildschirmfoto am 2013-02-16 01:49:43.png

Bildschirmfoto am 2013-02-16 01:50:58.png

Bildschirmfoto am 2013-02-16 01:52:23.png
0
I'm glad things worked out for you in the end.
Since this flag is a new option of IDEA 12, we should perhaps update http://confluence.jetbrains.com/display/MPSD25/Using+MPS+inside+IntelliJ+IDEA with an explicit warning.
Would this have helped in your case?

Vaclav
0

Please sign in to leave a comment.