MPS 3.0 migration restrictions

Yesterday I was brave enough to have a closer look to MPS 3.0 and tried to migrate my language project. As exiting I was before as disappointed I am now.

On two 64 bit Kubuntu systems with the openJDK 1.7 I can't open existing projects or create a new one with MPS 3.0. The window with the status bar just freezes. On a openSUSE system this part works fine, with openJDK and Oracle JDK.

The second problem was that the last migration scripts of a not cleaned project (containing files generated by MPS 2.5) take so much time and spread the terminal with so many messages, that I canceled the procedure (See MPS-18789). Sometimes the migration also freezes.

After cleaning all generated files the migration succeeds after an adequate time. But now  I am having a project (8 languages and 8 solutions) with errors everywhere. When I start the type check for the whole project my system I ran into an out of memory error. Doing this just for my main language leads to about 2000 errors. As far as I remember I could solve 8 automatically with quick fixes. After a short look to the errors I give up. Most of them I do not understand and I can't see a common reason. I've tried to optimize the imports and build the languages with errors, without success.

Before digging in the errors, I would really like to know which preconditions must be met in a MPS 2.5 project to migrate successfully to MPS 3.0. Is there any documentation about it?
1 comment
My migration project is still very frustrating. In this context I provide these two bugs: MPS-18794, MPS-18794
I could solve a few errors, but most of them not. The type and scope system seems be going crazy. Checking just a single aspect of my language can take up to several minutes.
But the strange errors are not restricted to my code. For example I opened the SAbstractConceptAdapter class because of the above bugs. I looks like this:
SAbstractConceptAdapter.png

Is my MPS installation broken or do these errors really exist? Type errors like this are everywhere in my code, too. If the included code is not working with the new type system, I don't really think that I could make my languages work fine with MPS 3.0.

The good message is, that MPS now runs on Kubuntu with the oracle JDK. A warning message at startup like in intellij would be nice, if the openJDK is not supported.
0

Please sign in to leave a comment.