MPS facet in IntelliJ 13.0

I am using IntelliJ 13.0 (133.193). I started working with MPS 3.0 (129.438) using the tutorials in MPS standalone mode. This worked well. Then i wanted to use MPS facet inside IntelliJ. I used the MPS menu "Tools->Install IntelliJ IDEA plugin". Now i see a "Jetbrains MPS Integration" plugin installed, but i cannot use the MPS facet. The settings and project structure panels know nothing about MPS.
Then i tried to install the MPS plugins from disk as described in http://www.jetbrains.com/mps/download/ But these plugins are not accepted because of incompatible versions. They appears red in the plugin list. My questions is: What is the correct way to use MPS facet in IntelliJ 13.0 ? Or is the solution to go back to version 12 for now ?
3 comments
Hi Andreas,

yes only IDEA 12 is supported by MPS 3.0.2
Then use the IDEA's plugin manager to download and install the plugins or down load them separately and install from disk, as you describe.

Vaclav
0
So, are there any dates on when MPS plugin will be supported in IDEA 13?
0
Hi!
Actually MPS 3.0.4 already supports idea 13, but only 13.0 and NOT 13.1
We're going to release MPS 3.1 EAP very soon. That one will support idea 13.1
0

Please sign in to leave a comment.