Index taking forever

Fresh installation - upon starting, it is continously running "scanning / index" background task that is taking 100% cpu and large disk IO.

It has been running for more than 30 minutes - and unable to use the app at all.

Somewhere someone suggested "invalidate the cache" etc., - tried those approaches. Restarting after invalidating the cache did not make any difference - still taking long hours continuously running.


Wondering what has it to index on a fresh installation? I want to disable this index thing - since I am unable to use the application at all. Please inform how to disable it


This is definitely unusual behavior. I suspect there might be some problem accessing the folder that stores the MPS index files (USER_HOME/.MPS3.3/system). I suggest that you check the contents of the folder and perhaps manually delete it and restart MPS.




Another possibility is that you have a virus scanner running that does on-access scan of all kinds of files. Since MPS needs to do a lot of file I/O for making the index, a virus scanner can slow it down substantially.

If this is the case, then you could add some folder exclusions like $HOME/.MPS* and the folder where you installed/unpacked MPS.


Thank you.

Did both (remove the index files manually, as well as excluding the Folder from scanner) - but no difference. The cache files are regenerated with 57MB+ and indexing still going on. (Refer below screenshot)

BTW, disk I/O counter is not much, it is the CPU that is going to 98% (intel i7 2.4Ghz+ CPU).


What exactly is this indexing? And how to turn it off? What is the expected cache file size (it is now at 58MB)


One thing observed is: after the file content.dat.storageData reached the 57,063 KB size (as shown above), no matter how long the index is running, it is not increasing in size any further. But still consuming the CPU and running indefinitely

How to stop this? I am unable to use MPS, and desperately waiting for somehow to start using it


The CPU drain looks to me exactly like the problem that a virus scanner is slowing down MPS, giving it a lot of overhead in computing. Did you exclude both folders? The one in your home and the one where you installed MPS?

I don't know which installer you used. For Windows, I myself don't use the standard .exe installer, but the unified package ( I unzip this and then run mps.bat. Maybe it helps uninstalling everything, deleting the entire .MPS* folder in your home and then try this unified version.

What java version are you running? I would recommend one of the newer 1.8 versions, as they have very nice performance improvements.

Are you doing this on a computer from work? You could check with your administrator to see what is the problem...

I tried briefly connecting with jconsole.exe to the MPS java process, but I didn't succeed (connection failed). However, you may succeed, getting more hints on which part of MPS is hampered in its progress.


Thank you. Uninstalled and used the zip version you have suggested. Now, when opening any sample project, the indexing is fast. No more trouble.

However, while opening this particular sample it is exhibiting the same "forever indexing" behavior.

It is a Meta R example, very basic one (from here)


I applied migrations on the tutorial project and pushed to the repo. I used MPS 3.3.4 to run migrations, and did not see any indexing issue on mac. After applying migrations the indexing issue was resolved on Gopalakrishna Palem's machine, as reported to me on gitter. 


Please sign in to leave a comment.