[Solved] Root concepts don't show in sandbox solution

Hi guys,

I followed this tutorial: https://www.youtube.com/watch?v=xXmYE9HrooM

I also tried other tutorials but it all comes down to:
I create a concept, set "instance can be root" to true,
try to create an instance in the sandbox solution,
but "New" only contains "Test Model"...

I have no idea what I am doing wrong here.
When adding baseLanguage as a Language to the sandbox,
I am able to instantiate the root concepts of the base lang, but still not mine.

As this might be relevant: I am using the current MPS EAP (3.4)

Thanks for your help

2 comments

Hi,
assuming you rebuilt your language and you have your language specified as a "Used language" in your sandbox model, it might be caused by a bug that was present in the EAP releases, which prevented the "Create new" menu from being notified about new Concepts having been created - https://youtrack.jetbrains.com/issue/MPS-24138
There was no reliable way to workaround this issue, but you may try creating another concepts, restarting MPS or invalidating caches. Alternatively you could get a newer version of MPS - Public Preview might have it fixed.

Cheers,
Vaclav

1

After trying MPS 3.3.5 I can confirm that this problem seems to be related with the EAP.
In 3.3.5 it simply works :-)

Restarting the EAP did not help in my case and I don't know go to invalidate the caches.
Anyways adding a second concept made the first one available in the "New" menu.
The issue you linked sounds exactly like my problem.

 

0

Please sign in to leave a comment.