View Node Explorer is disabled

It is so frustrating to follow instructions and videos and get stopped right out the gate. I tried installing it twice, I rebooted the computer and I searched everywhere with no luck.

Is there some reason that roughly half of the options in View / Tool Windows are disabled? In particular the videos mention Node Explorer. Pressing F-12 brings up the Terminal not the Node Explorer.

Thanks for any pointers.

4 comments
Comment actions Permalink

The key shortcut for Node Explorer changed recently to Control + X.

0
Comment actions Permalink

I appreciate the quick response but that doesn't seem to work. Something called a Typesystem Trace window just appeared.

Generally speaking though why are all the tool windows disabled in the menu? Shouldn't they be available outside of a keyboard shortcut? I'm just concerned that I didn't install an optional set of plugins or something. This is like step 2 of getting started.

I also received an error when I changed the settings Appearance / Theme to Windows. And I received another one when I tried to report that error.

I'd settle on seeing the Node Explorer for now.

Thanks.

0
Comment actions Permalink

Ok, it is Alt + X on Windows.

If you're struggling to find a shortcut for an action, you can use Control + Shift + A and type (part) of the name of the action to find and trigger it.

Tool windows react to the context, in which you try to open them. The disabled ones have no content relevant to the context of where the cursor is. BTW, there's a toggle button in the bottom left corner of the window that shows/hides all tool panel buttons. Then you can open/hide the tool windows with mouse using those buttons that show up on the sides of the MPS frame.

 

0
Comment actions Permalink

I am using Windows. The Ctrl+Shift+A helped and I see "Show Node in Explorer Alt+X". When I select it I finally get the Node Explorer. And I can now select code or the entire Maze script and see it in the Node Explorer.

I shut down the editor and started again. It seems that highlighting a part of the script (while block for instance) and pressing Alt+X doesn't work but selecting the entire script and pressing it does. And I noticed when the script is all selected the right mouse click menu has the Node Explorer active as well.

I think I got it. I inferred from the video that the block of code needed to be highlighted but it is only the node so I can right click on turnLeft for instance and get the display.

Back in business, thanks.

1

Please sign in to leave a comment.