Problems creating a standalone IDE

I am trying to create a build script to my language. I keep getting this error and I don't know how to solve. I have already read the Getting the dependencies right, but I am sure it's not a bootstrap dependency.

Could anyone give some tip?

5 comments

"dependency on a module not visible from current build project" means you need to add the build script of that other project to your build script's dependencies:

0

Thanks for the help! Solved this problem, but couldn't solve other problems that came after that. :S

Now, this is the error I am receiving:

I have tried to write these dependencies on the field bellow where it is named dependencies inside idea plugin.

I also tried to write these dependencies on the field naned dependency on the top of the script.

Couldn't solve either.Finally, I also tried to add these dependecies through ctrl+R.

 

 

I also think is helpful to print here what I've done to solve the previous error. I have installed the mbeddr and IETS3 things as Markus Voelter teaches in his tutorial on YouTube.

I also keep receiving errors when I try to rebuild the build model. I wrote a java library to assist my language and I imported it as a solution model the way  Fabien Campagne suggests in his book (I create a solution, extend JDK, add the library on the Java aspect and then add a model root and the set the .jar as a source). When I try to rebuild the build model, it says it can't find the .jar, even though it works perfectly fine on my sandbox.

I also created a DevKit with some languages and it's the only dependency my sandbox model depends. Should I add the DevKit to build script? What the tutorial suggests is to just not add the sandbox solution.

 

0

Hi Matheus,

regarding unsatisfied dependencies: the message lists modules but you need to find out which plugins include those modules and add dependencies on those plugins. I wrote a blog post with more details on how to figure out which plugins to add.

The .jar problem is solved by adding the JAR to the build script under the plugin. Federico Tomassetti's article on adding JARs covers this in the last section.

You should add the devkit to the build script since you probably intend to distribute it to the users of your language. You don't need to add the sandbox solution unless you want it built as part of the overall build.

0

I am still with troubles, different ones, but trouble.

Now my build script has no type system errors, :). But the generator still not generates.

I have a runtime solution that is a .jar that I have set the way Federico Tomasseti teaches in his article. I am receiving the same error of his:

Obviously, I have tried Tomasseti's solution:

 

But the things seem different when I am running a Standalone IDE plugin:

 

 

I added to the default folder children that were generated by the wizard a zip, just the way Tomasseti teaches. But I keep receiving this error when I try to rebuild the solution and the "preview generated text" does not work.

I think it is something specific to Standalone IDE's build scripts because when I tried to create a build script for an MPS Plugin it worked with Tomasseti's suggestion.

Any advise?

0

I don't know if the [CENSORED] plugin in the [CENSORED].zip is the same as the [CENSORED] plugin in the plugins folder but if it is, then there are two things I'd try:

1. You probably need to add the resources_project.jar to that plugin as well.

2. I vaguely remember that the build language generator may get confused if you have the same plugin twice in the layout like you do. Try only adding it there once.

0

Please sign in to leave a comment.