Not generating java when rebuilding project

Hello!

I created language plugin and loaded it into MPS. Then I created new project and a model with my language. All is ok and works.

But then I want to run this model. But I see always "generation required" message. And I tried Rebuild project, make project, restarting MPS etc. It does not help.

In previous version 2019.1 all works fine.

Preview generated text works and shows correct Java with main function. But generation is not run when rebuilding project.

Where can be the problem?

5 comments
Comment actions Permalink

This looks like a bug to me. Can you share more details about the project, especially about the generator? Maybe create a YouTrack issue with the project attached?

Vaclav

 

0
Comment actions Permalink

Project is here https://github.com/d0sl/d0SDK

1) git clone https://github.com/d0sl/d0SDK
2) install plugin d0sl-plugin-mps-0.8.9.zip from plugin catalog
3) Open project in MPS 2019.3.4

in org.d0sl.examples there are auto and chess - this is java models
and org.d0sl.examples.sandbox contains DSL models

If the project is build correctly then you can run 

AutodromeAII

ChessAII

MathTest

 

0
Comment actions Permalink

Linux Ubuntu

I tried  MPS from Toolbox, and also downloaded latest version from site.

Problem is that MPS does not generate java classes for org.d0sl.examples.sandbox

But if I generate and place one manually. Then I can run the corresponding model. And after that MPS creates others java for the DSL models.

0
Comment actions Permalink

I followed your scenario and things worked just fine after I fixed two broken references in ChessFrame and Autodrome (both were pointing to an unresolved EXIT_ON_CLOSE field). The generator was failing with errors for me when I checked out. Maybe that was the issue you were having?

After that change I can rebuild the project and run the nodes. Cute animations, BTW.

0

Please sign in to leave a comment.