Diagramming Editor in MPS 2020.2

Hello,

 

The Diagramming Editor in MPS 2020.2 does not work as described in the document (https://www.jetbrains.com/help/mps/diagramming-editor.html ).

 

First I tried the mindMaps sample. There was no way to delete characters from the names of Thought concepts; a new character could be added to a name by first selecting a thought and then typing the character, but all typed characters thereafter went to the name of the MindMap concept.

 

Then I tried the componentDependencies sample. The behavior of modifying, say, subsystems of Component concepts were the same as in the mindMaps sample. And dragging from an outgoing port to an incoming port did not create a connection.

 

What is the status of the Diagramming Editor currently?

 

Thanks in advance.

1 comment
Comment actions Permalink

The bundled version is abandoned and no longer maintained. Use the diagram editor in MPS-extensions instead. https://jetbrains.github.io/MPS-extensions/

1

Please sign in to leave a comment.