Hi all, I have created a language with new concepts, these concepts each have a icon described (as below), and they display all the time my language is open in an editor. However when I use the lang...

This is an auto-generated question from the MPS Slack community: Hi all, I have created a language with new concepts, these concepts each have a icon described (as below), and they display all the time my language is open in an editor. However when I use the language as a dependency the Icons never render as expected, any ideas?
6 comments
Comment actions Permalink
Do you mean you pack your language as a plugin and use this language? I didn’t get what you mean by use the language as a dependency.
0
Comment actions Permalink
Sorry we pack the language as a plugin
0
Comment actions Permalink
Here is a problem. a href='https://youtrack.jetbrains.com/issue/MPS-25087#focus=Comments-27-4309768.0-0'Here/a is the way to make icons work (if not then check other comments under this issue)
0
Comment actions Permalink
Slack user:U6M94JMGX> thanks for this, not sure I follow though, where is the java options part of the build script? 'offered me to add _*java options*_ section in the build script, set _*copy resources*_ in _*true*_ -> _*resource patterns*_ cell will appear'
0
Comment actions Permalink
In the build script find `project structure` and add a node under it (`project part` cell should be created). Open completion and find `java options` .
0
Comment actions Permalink
This is auto-generated question from the MPS Community Slack Workspace. If you want to comment on the question, do it from the Slack workspace
0

Post is closed for comments.