JetBrains MPS has failed to load the environment from '/bin/zsh

Hello everyone.

I am using macOS 12.4 that uses zsh by default.

Every time I start MPS, either by the terminal (executing ./mps) or by clicking in the icon I always get the message "JetBrains MPS has failed to load the environment from '/bin/zsh'. Integration with tools that rely on environment variables may work incorrectly."

Since I am trying to use mbeddr with MPS (MPS version 2021.2.5) I think that some features of mbeddr are not working because MPS is not able to execute the integrated tools (e.g., gdb, nusmv, cbmc) because he is not able to read the env variables.

I already tried the workaround in https://youtrack.jetbrains.com/articles/IDEA-A-19/Shell-Environment-Loading but with no success. I also tried to change the default shell and also no luck.

Is there a way to see what env variables are read by MPS? Can I get this information to be exported to the log file?

Any help is very welcome.

Thanks.

Please sign in to leave a comment.