Unable to add jetbrains.mps.devkit.general-purpose as dependency

I am trying to build a standalone IDE for my DSL.

I have successfully created all concepts, editors, and generators, and everything works as planned.

However upon attempting to build the standalone IDE, this error pops up:

I haven't been able to find any way to resolve this. I have tried adding the devkit under the dependencies of the solution, and also under languages of the model itself, and even as a dependency for the generator. Yet I have still not found a solution to this problem.

Any help or clues pointing me in the right direction would be very much appreciated as I've spent quite some time trying to figure this out and just can't figure it out.

5 comments
Comment actions Permalink

Did you read this forum post?

https://mps-support.jetbrains.com/hc/en-us/requests/2025027

I had big issues in the building of standalone IDE (in fact, we gave up from the standalone IDE and delivered in the regular MPS IDE)

0
Comment actions Permalink

Thanks for the quick reply.

I'm at this point quite aware how impossible the bundling is, but I just want to get it to work on this one project.

Regarding the other post - I can't look at it. The link leads me to an error 404 page.

0
Comment actions Permalink

My problem was that I had circular dependencies. Did you check it?

 

Other forum post I made, this time with my real project, was this one: https://mps-support.jetbrains.com/hc/en-us/community/posts/360004407199-Problems-creating-a-standalone-IDE

This time, I hope, you won't get a 404.

0
Comment actions Permalink

Ulrich Barnstedt what does your build script look like? Do you have mps in the dependencies section?

0
Comment actions Permalink

Thanks for both your help.

Matheuscampos, I had a look at the post that you linked but I wasn't able to to determine any similar problems in my own project.

Sergej Koščejev, I do have a mps dependency, my dependencies look like this:

 

0

Please sign in to leave a comment.